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Error: "Browser version is not supported"

About the article

In this article you will learn what to do if you get the error message: "Browser version is not supported".

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Pre-requisites

 
  • Internet Explorer 10 or higher

 

1. Error message

browser_version_not_supported_1.png

 

 
  • The error message shows even though Internet Explorer 11 or higher is installed

 

browser_version_not_supported_2.png

 

2. Cause

This error occurs when Display intranet sites in Compatibility View is set in Internet Explorer.

 

browser_version_not_supported_3.png

 

3. Solution

To resolve the issue, either remove the checkmark in Display intranet sites in Compatibility View (Recommended), or remove *.templafy.com from trusted Local intranet sites. 

 

 
  • Note: You should only use the second option if compatibility view is required.

 

    3.1 How to disable Compatibility View (Recommended option)

          3.1.1 Open Internet Explorer

          3.1.2 Click the Cogwheel (Settings)> Click Compatibility Viewsettings

 

browser_version_not_supported_4.jpg

 

          3.1.3 Uncheck Display intranet sites in Compatibility View.

browser_version_not_supported_5.jpg

 

 

    3.2 How to remove Templafy from Local intranet sites (Secondary option)

          3.2.1 Go to Internet Options > Security > Local Intranet and choose Sites

          3.2.2 In the Local intranet dialogue box choose Advanced 

          3.2.3 Remove *.templafy.com from the list of trusted Local Intranet websites.  

  browser_version_not_supported_6.png

 

    3.3 How to reset Internet Explorer browser settings to default (Last option)

          3.3.1 Select the Tools button, and then select Internet options

          3.3.2 Select the Advanced tab, and then select Reset

          3.3.3 In the Reset Internet Explorer Settings dialog box, select Reset

          3.3.4 When Internet Explorer finishes applying default settings, select Close, and then select OK

          3.3.5 Restart your PC to apply the changes.

 

browser_version_not_supported_7.png

 

4. Simulation

Another thing worthwhile checking, is if the user agent string is set to the highest version:

      4.1 In Internet Explorer, press F12.

      4.2 Click Emulation.

      4.3 Scroll down to the bottom in the window that opens, and check that the User Agent String is set                to Internet Explorer 11 (Default):

 

browser_version_not_supported_8.png

 

To determine the emulation version from the Templafy VSTO add-in can one use the Windows F12 tool (also known from Edge and IE). It can simulate a "browser instance" that's not actually running in a browser, simulating the behavior of the Templafy VSTO plugins.

4.1) Please open an Office application such as Word including the Templafy add-in

4.2) The F12 tools can be found in the "F12" folder under "system32 " C:\Windows\System32\F12

4.3) Start the F12 tools with the IEChooser.exe

4.4) Choose one of Templafy Office application instances

browser_version_not_supported_9.png

4.5) Switch to the emulation tab and confirm the version number.

browser_version_not_supported_10.png

4.6) Templafy supports the user agent string version 10 and higher (version 11 is the default setting). The desktop application distributes a registry key that usually enforces the correct version for all Templafy Office add-ins. Please confirm that the registry keys are set at: 

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION 

browser_version_not_supported_11.png

 

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